ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Red and Black(DFS)

2021-02-09 19:30:06  阅读:233  来源: 互联网

标签:tiles 22 int DFS Black tile black Red he


题目:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

思路:DFS

实现代码:

#include<cstdio>
#include<cstring>
using namespace std;
int w,h,sum;
char map[22][22];
int dis[4][2]={{1,0},{-1,0},{0,-1},{0,1}};

void dfs(int x,int y)
{
	int nx,ny,i; 
	map[x][y]='#';
    sum++;
	for(i=0;i<4;i++)
	{
		nx=x+dis[i][0];
		ny=y+dis[i][1];
		if(map[nx][ny]!=0&&map[nx][ny]!='#')
		 dfs(nx,ny);
	}
}
int main()
{
	int i,j,p,q;
	while(~scanf("%d %d",&w,&h))
	{
		getchar();
		if(w==0&&h==0)
		break;
		memset(map,0,sizeof(map));
		for(i=1;i<=h;i++)
		{
			for(j=1;j<=w;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					p=i;
					q=j;
				}
			
			}
			getchar();
		}
		sum=0;

		dfs(p,q);
		printf("%d\n",sum);
	}
    return 0;
} 

注意:用这种提前把地图(题中所给的最大范围)所有都标记为0,然后输入我们要搜索的地图,直接在地图上更改的,要注意定义的大小!!这里char map[22][22],不可以是21!!大于22也可。for for的输入,也是从i=1,j=1,开始哦,相当于我们把最大范围20外面围了个0的圈子,所以是22。

标签:tiles,22,int,DFS,Black,tile,black,Red,he
来源: https://blog.csdn.net/with_wine/article/details/113774594

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有