ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT A1048 Find Coins (25分)(二分法)

2020-03-13 12:42:01  阅读:247  来源: 互联网

标签:25 PAT int coins 二分法 amount she each line


题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805432256675840

题目描述
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10^​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

输入
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10^​5​​ , the total number of coins) and M (≤10^​3​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

输出
For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​ +V​2​​ =M and V​1​​ ≤V2​​ . If such a solution is not unique, output the one with the smallest V​1​​ . If there is no solution, output No Solution instead.

样例输入
8 15
1 2 8 7 2 4 11 15

样例输出
4 11

代码

#include <iostream>
#include <algorithm>
using namespace std;

int a[100010];

int main() {
	int i, n, m;
	scanf("%d%d", &n, &m);
	for(i = 0; i < n; i++)
		scanf("%d", &a[i]);
	sort(a, a + n);
	for(i = 0; i < n; i++) {
		int j = lower_bound(a, a + n, m - a[i]) - a;
		if(j != i && a[i] + a[j] == m) {
			printf("%d %d\n", a[i], a[j]);
			break;
		}

	}
	if(i == n)
		printf("No Solution\n");
	return 0;
}

标签:25,PAT,int,coins,二分法,amount,she,each,line
来源: https://blog.csdn.net/Rhao999/article/details/104838351

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有