ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

【递推】Fibonacci Again

2020-01-24 10:07:17  阅读:305  来源: 互联网

标签:Again no int 样例 Fibo Fibonacci Print yes 递推


描述

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

输入

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

输出

Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

样例输入

0
1
2
3
4
5

样例输出

no
no
yes
no
no
no

题目来源

HDOJ
分析:斐波那契递推。
代码:
#include<bits/stdc++.h>
using namespace std;
int f[1000001];
void Fibo()
{
f[0]=7;f[1]=11;
for (int i=2;i<1000001;i++)
f[i]=(f[i-1]+f[i-2])%3;
}
int main()
{
Fibo();
int n;
while(cin>>n)
{
if (f[n]%3==0)
cout<<“yes”<<endl;
else
cout<<“no”<<endl;
}
return 0;
}

Skynamer 发布了69 篇原创文章 · 获赞 0 · 访问量 1770 私信 关注

标签:Again,no,int,样例,Fibo,Fibonacci,Print,yes,递推
来源: https://blog.csdn.net/Skynamer/article/details/104079423

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有