ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Currency Exchange(SPFA判负环)

2019-07-01 22:44:14  阅读:220  来源: 互联网

标签:include exchange int point 判负 SPFA edge Currency id


Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<vector>
#include<cmath>
#include<map>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
const int Inf=0x3f3f3f3f;
struct edge
{
    int to;
    double r;
    double c;
    int next;
} edge[maxn];
 
int n,m,s;
double v;
int len;
int head[maxn];
double dis[maxn];
int vis[maxn];
int num[maxn];
void add(int u,int v,double r,double c)
{
    edge[len].to = v;
    edge[len].r = r;
    edge[len].c = c;
    edge[len].next = head[u];
    head[u] = len++;
}
bool spfa()
{
    queue<int > q;
    dis[s] = v;
    q.push(s);
    vis[s] = 1;
    num[s]++;
    while(!q.empty())
    {
        int t = q.front();
        q.pop();
        vis[t] = 0;
        for(int i = head[t];i!= -1;i = edge[i].next)
        {
            int id = edge[i].to;
            if(dis[id]< (dis[t]-edge[i].c)*edge[i].r)
            {
                dis[id] = (dis[t]-edge[i].c)*edge[i].r;
                if(vis[id] == 0)
                {
                    q.push(id);
                    vis[id] = 1;
                    num[id]++;
                    if(num[id]> n)
                        return 1;
                }
            }
        }
    }
    return 0;
}
void init()
{
    for(int i = 1;i<= n;i++)
        dis[i] = -1;
    memset(vis,0,sizeof(vis));
    memset(num,0,sizeof(num));
    memset(head,-1,sizeof(head));
}
int main()
{
    cin>>n>>m>>s>>v;
    init();
    for(int i = 1;i<= m;i++)
    {
        int a,b;
        double ra,rb,ca,cb;
        scanf("%d %d %lf %lf %lf %lf",&a,&b,&ra,&ca,&rb,&cb);
        add(a,b,ra,ca);
        add(b,a,rb,cb);
    }
    if(spfa())
        cout<<"YES"<<endl;
    else
        cout<<"NO"<<endl;
    return 0;
}

 

标签:include,exchange,int,point,判负,SPFA,edge,Currency,id
来源: https://www.cnblogs.com/Staceyacm/p/11117229.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有