ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT-1015 Reversible Primes

2022-02-11 10:32:09  阅读:199  来源: 互联网

标签:prime return No int num Reversible 1015 Primes Yes


1015 Reversible Primes (20 分)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10^5) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

解法

这题没啥好说的,最后一个测试点测的是检查原数字本身是不是素数!!!!看清楚定义!!!

from math import sqrt
def isp(n):
    if n < 2: return False
    for i in range(2, int(sqrt(n)) + 1):
        if n % i == 0: return False
    return True

def convert(n, r):
    ans = ''
    while n > 0:
        ans += str(n % r)
        n //= r
    return ans
    
while True:
    n = input().split()
    if len(n) == 1: exit(0)
    num, r = [int(i) for i in n]
    if num < 0: exit(0)
    y = int(convert(num, r), r)
    if isp(num) and isp(y): print("Yes")
    else: print("No")

标签:prime,return,No,int,num,Reversible,1015,Primes,Yes
来源: https://blog.csdn.net/pxy7896/article/details/122840329

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有