ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT-A1048 Find Coins (寻找硬币)

2021-09-25 18:34:31  阅读:143  来源: 互联网

标签:Coins PAT int coins A1048 Sample V1 she line


A1048 Find Coins (寻找硬币)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15结尾无空行

Sample Output 1:

4 11

结尾无空行

Sample Input 2:

7 14
1 8 7 2 4 11 15结尾无空行

Sample Output 2:

No Solution

结尾无空行

分析:

这道题目也不难,就是要注意当钱的数值是一样的时候,要看看是否有两个值

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std; 
bool HashTable[100010]={false};
int num[100010]={0};
int main(){
	int m,n,v1,v2,i;
	bool flag=false;
	int coin[100010];
	scanf("%d %d",&m,&n);
	for(int i=0;i<m;i++){
		scanf("%d",&coin[i]);
		num[coin[i]]++;
		HashTable[coin[i]]=true;
	}
	sort(coin,coin+m);
	int min=100;
	for(i=0;i<m;i++){
		if(HashTable[n-coin[i]]){//可以输出 
		if(coin[i]==(n-coin[i])){
			if(num[coin[i]]!=1){
				flag=true;
			    break;
			}
		}else{
			flag=true;
			break;
		}
			
		}
	}
	if(flag) printf("%d %d",coin[i],n-coin[i]);
	else printf("No Solution");
	return 0;
} 

标签:Coins,PAT,int,coins,A1048,Sample,V1,she,line
来源: https://blog.csdn.net/weixin_46055626/article/details/120475398

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有