ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

XYZZY(SPFA判正环)

2021-09-06 19:58:02  阅读:179  来源: 互联网

标签:判正环 room power int energy 60 SPFA rooms XYZZY


It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 

the energy value for room i 
the number of doorways leaving room i 
a list of the rooms that are reachable by the doorways leaving room i 
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case. 

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless". 

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1
Sample Output

hopeless
hopeless
winnable
winnable

题意:从第一个房间开始有100的初始能量。每经过一个房间加上此房间的能量值,如果能量为负或者到达终点则停止。问能不能到达终点。

题解:首先先用Floyd判断连通性,如果不连通则结束。如果联通用spfa判断有没有正环,即cnt[v]>=n则有正环,有正环判断环上一点到终点是否联通。没有环的话,则判断到达终点最长的通路能量值是否大于0即可。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 105;
const int INF = 0x3f3f3f3f;
int n;
int energy[maxn];
int power[maxn];   //记录到每一点的力量值
int cnt[maxn];   //记录访问每一个点的次数
bool g[maxn][maxn];
bool reach[maxn][maxn];
void floyd()
{
    for(int k = 1; k<=n; k++)
        for(int i = 1; i<=n; i++)
            for(int j = 1; j<=n; j++)
            if(reach[i][j]||(reach[i][k]&&reach[k][j])) reach[i][j] = true;
}
bool spfa(int s)
{
    queue<int> q;
    memset(power,0,sizeof(power));
    power[s] = 100;
    memset(cnt,0,sizeof(power));
    q.push(s);
    while(!q.empty())
    {
        int v = q.front();
        q.pop();
        cnt[v]++;
        if(cnt[v]>=n) return reach[v][n]; //有正环
        for(int i = 1; i<=n; i++)
        {
            if(g[v][i]&&power[i]<power[v]+energy[i]&&power[v]+energy[i]>0)
            {
                power[i] = power[v]+energy[i];

                q.push(i);
            }
        }
    }
    return power[n]>0;

}
void solve()
{
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {
        memset(g,false,sizeof(g));
        memset(reach,false,sizeof(reach));
        for(int i = 1; i<=n; i++)
        {
            int k,door;
            scanf("%d %d",&energy[i],&k);
            for(int j = 1; j<=k; j++)
            {
                scanf("%d",&door);
                g[i][door] = true;
                reach[i][door] = true;
            }
        }
        floyd();
        if(!reach[1][n])
        {
            printf("hopeless\n");
            continue;
        }
        if(spfa(1))
        {
            printf("winnable\n");
        }
        else
        {
            printf("hopeless\n");
        }
    }
}
int main()
{
    solve();
    return 0;
}

标签:判正环,room,power,int,energy,60,SPFA,rooms,XYZZY
来源: https://blog.csdn.net/lihuanz/article/details/89467370

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有