ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

每日一淦2021.8.24

2021-08-24 22:34:39  阅读:189  来源: 互联网

标签:24 一淦 yen int 2021.8 dollar Sample leq min1


ALDS1_1_D 在时间线上的最大利润。

Maximum Profit

You can obtain profits from foreign exchange margin transactions. For example, if you buy 1000 dollar at a rate of 100 yen per dollar, and sell them at a rate of 108 yen per dollar, you can obtain (108 - 100) × 1000 = 8000 yen.

Write a program which reads values of a currency $R_t$ at a certain time $t$ ($t = 0, 1, 2, ... n-1$), and reports the maximum value of $R_j - R_i$ where $j > i$ .

Input

The first line contains an integer $n$. In the following $n$ lines, $R_t$ ($t = 0, 1, 2, ... n-1$) are given in order.

Output

Print the maximum value in a line.

Constraints

  • $2 \leq n \leq 200,000$
  • $1 \leq R_t \leq 10^9$

Sample Input 1

6
5
3
1
3
4
3

Sample Output 1

3

Sample Input 2

3
4
3
2

Sample Output 2

-1

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main() {
int n,a[200000];
cin >> n;
for (int i = 0;i < n; i++)
cin >> a[i];
int min1 = a[0];
int max1 = -1000000000;
for (int i = 1; i < n; i++) {
max1 = max(max1, a[i] - min1);                 //max()和min()函数需要头文件带<algorithm>才能使用。
min1 = min(min1, a[i]);
}
cout << max1 << endl;
return 0;
}

标签:24,一淦,yen,int,2021.8,dollar,Sample,leq,min1
来源: https://www.cnblogs.com/NightVoyager233/p/15182836.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有