ICode9

精准搜索请尝试: 精确搜索
  • linux_x64编译Qt12.7源码2020-02-22 22:38:57

    因为用于平时学习用,所以就不裁剪模块了,秉着能多装功能就多装的原则 下载地址 qt-everywhere-src-5.12.7.tar.xz 需要安装的QT依赖库 apt-get install libqt4-dev libqt5* libfontconfig* libqtweb* libpng* libiconv* libdbus* ninja* apt-get install libglu1-mes

  • Scrapy初体验(一) 环境部署2020-02-22 21:51:25

    系统选择centOs 7,Scrapy是一个为了爬取网站数据,提取结构性数据而编写的应用框架。 可以应用在包括数据挖掘,信息处理或存储历史数据等一系列的程序中。 其最初是为了 页面抓取 (更确切来说, 网络抓取 )所设计的, 也可以应用在获取API所返回的数据(例如 Amazon Associates Web Servic

  • 几种 npm install XXX 的区别2020-02-22 16:55:07

    在使用npm命令安装资源包时,有哪些需要注意的区别 npm install X 会把X包安装到node_modules目录中 不会修改package.json 之后运行npm install命令时,不会自动安装X npm install X –save 会把X包安装到node_modules目录中 会在package.json的dependencies属性下添加X 之后运行n

  • centos上安装python环境2020-02-22 16:51:00

    1、安装python-pip​ 首先安装epel扩展源: ​ yum -y install epel-release ​ 更新完成之后,安装pip: ​ yum -y install python-pip 2、安装python依赖包:​ 初次直接运行: ​ pip install -r requirement.list ​ 如果是裸的centos绝对会报错! ​

  • Mac - MacOS降级,任意系统回退2020-02-22 14:52:25

    前言 最近把macOS更新到了 macOS Catalina,使用了一段时间后,结合自己的使用环境和体验,感觉 Catalina 不太好用,就想把系统回退到 macOS Mojave,但是平时几乎不用时间机器去备份,所以若想要回退版本,只有一个办法:下载“安装 macOS Mojave”应用程序, 制作引导盘,备份自己重要的东西(我的东

  • npm install 、npm install --save 和 npm install --save-dev的区别2020-02-22 13:06:06

    相同点 三者都会本地安装包到项目的node_modules目录中 区别 区别在于对项目package.json的修改,npm install不会修改package.json,而后两者会将依赖添加进package.json,后两者的区别请看下文循序渐进。 指定依赖包 指定包取决于你的项目,你需要在package.json 文件中列出你需要使

  • 项目环境搭建【Docker+k8s】二 || centos7服务器通用设置2020-02-21 22:58:41

    1、设置静态ip和DNS   该教程使用虚拟机进行安装,安装前设置虚拟机静态ip和DNS。教程:虚拟机安装centos7教程 2、关闭防火墙 systemctl stop firewalld && systemctl disable firewalld 3、设置主机名 #hostname主机名自定义 hostnamectl set-hostname <hostname> 4、关闭selinux

  • 1366, "Incorrect string value: '\\xF0\\x9F\\x91\\x89\\xE3\\x80...' for co2020-02-21 22:53:42

    问题描述:Python从网站中抓取网页文本保存到MySQL数据中,对应数据库字段为longtext,字符编码utf-8。部分插入成功,部分插入失败,报错如下。1366, "Incorrect string value: '\\xF0\\x9F\\x91\\x89\\xE3\\x80...' for column 'content' at row 1"是因为mysql不能识别4个字节的utf8编码的

  • python中pip问题2020-02-21 22:01:23

    1.在cmd中运行pip命令显示‘pip命令显示不是内部或外部命令,也不是可运行的程序或批处理文件’的问题    先看python的安装目录下Script文件夹中pip3.exe有没有缺失    如果没有在cmd中输入:python -m ensurepip 将pip.exe文件下载下来;    如果有,就应该没有把pip添加进环境变

  • maven项目pom.xml文件Maven install时报错2020-02-21 20:03:30

    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.2:compile (default-compile) on project mall-manager-web: Compilation failure [ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather tha

  • full2020-02-21 19:59:21

    ### Vue.js  ## 一、 单文件组件 ### 1. .vue文件     .vue文件,称为单文件组件,是Vue.js自定义的一种文件格式,一个.vue文件就是一个单独的组件,在文件内封装了组件相关的代码:html、css、js     .vue文件由三部分组成:<template>、<style>、<script>        

  • 一个简单的网络共享下载网盘(需python3.6.1及以上)2020-02-21 11:36:55

    环境安装:python3.6.1及以上 1. pip install uvicorn 2. pip install fastapi 3. pip install aiofiles 如果觉得这样安装太慢,那就选择国内源安装吧! 我这展示一个豆瓣源安装:pip install uvicorn -i https://pypi.douban.com/simple 接下来就编写代码吧: 我们在Download.py: #

  • 【异常】tensorboard 1.14.0 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.32020-02-20 18:04:41

    问题描述: pip 安装 tensorflow 时,出现异常提示,具体如下: pip install tensorflow 出现如下错误提示(setuptools 版本太旧 , wrapt 不能卸载): tensorboard 1.14.0 has requirement setuptools>=41.0.0, but you'll have setuptools 40.6.3 which is incompatible. Cannot uninstal

  • (原)Vue 单文件组件安装 (创建vue-cli 项目)2020-02-20 15:56:14

    更新于20200220   题外话:久违了我的博客园 正题:   1、准备工作,安装环境       1、安装node 官网下载安装即可  -- 配置环境变量   2、安装npm (基于node.js 包管理器)   3、安装cnpm (淘宝镜像,防止网速问题影响)   4、安装 vue-cli 脚手架    ----->   cnpm in

  • 一种不错的Jar打包方式2020-02-20 15:54:09

    一、说明 二、解决方案   在要打包输出的子模块中的pom.xml中配置下列代码。 <build> <plugins> <plugin> <groupId>org.springframework.boot</groupId> <artifactId>spring-boot-maven-plugin</artifactId> </plugin>

  • and Python interface2020-02-20 15:05:39

    Ubuntu 16.04 LTS OpenCV C / C++ and Python interface (接口) Install OpenCV from the Ubuntu Repository (apt) - Python 调用接口 Python3 sudo apt update sudo apt install python3-opencv 1 2 Python2 sudo apt update sudo apt install python-opencv 1 2 OpenCV

  • node.js 出现cannot find module 'xxx' 解决办法2020-02-20 14:10:22

    找不到模块的解决方案 : 把node_module整个文件夹删掉,然后npm clean cache,看下package.json里有没有express的依赖项,有的话直接npm install,没有的话 npm install express --save 点赞 收藏 分享 文章举报 a_靖

  • CentOS7中搭建redis单机2020-02-20 11:02:12

    1、安装gcc yum -y install gcc     2、在/usr/local下新建redis目录,下载redis安装包             3、解压缩        4、进入解压缩后的目录,进行编译:make   编译有问题可以用:make MALLOC=libc 5、进入src,安装:make install       6、启动Redis服务 启动redis服务:./

  • phpstorm教程-相同单词高亮显示2020-02-20 10:55:11

    1、安装BrowseWordAtCaret插件,如图所示,作者这里已经安装过,在你的工具中会显示Install按钮,点击Install安装即可,安装完成后会提示重启开发工具idea,重启即可。2、启用BrowseWordAtCaret插件,如图所示3、设置高亮颜色,如图所示4、查看设置效果,如图所示

  • Docker-(一).安装2020-02-19 21:02:23

    https://www.jianshu.com/p/e6b946c79542 国内 移除掉旧的版本 yum remove docker docker-client docker-client-latest docker-common docker-latest docker-latest-logrotate docker-logrotate docker-selinux docker-engine-selinux docker-engine 删除所有

  • electron-vue中使用serialport串口2020-02-19 18:06:49

    第一步:配置环境 1.安装 Python2.7 配置环境变量(官网下载)看网上说明必须是2.7版本,3不支持 2.安装 npm install --global --production windows-build-tools 3.安装 node-gyp npm install -g node-gyp 第二步:安装 1.安装 serialport npm install --save serialport 2.安装 ele

  • CentOS下升级Git1.7.1升级到Git2.2.12020-02-19 17:04:20

    卸载CentOS自带的Git 通过git --version查看系统带的版本,Cento6.5自带的是git版本是1.7.1 yum remove git 1、安装准备 yum install -y curl-devel expat-devel gettext-devel openssl-devel zlib-devel asciidoc xmlto perl-devel perl-CPAN autoconf* 2、下载git2.2.1并将gi

  • mvn clean -U -e -B -X的作用+如何在eclipse中使用mvn clean -U -e -B -X?2020-02-19 14:59:04

    如何在ECLIPSE中使用MVN CLEAN INSTALL 1、在Maven项目或者pom.xml上右键——>Run As ——>“Maven Build...”或者Run Configuration——>“Maven Build” 2、在“Goals”输入框中输入:clean install -X 3、使用时在Run As中选中Maven build即可     mvn命令若干: mvn -h

  • 【AI入门】之opencv安装2020-02-19 12:52:22

    安装命令     windows:Win+R打开运行,输入cmd(命令行工具),输入如下命令: pip install opencv-python #安装最新的OpenCV4.2.0.32开发包 pip install opencv-contrib-python #安装最新的OpenCV4.2.0.32扩展(可选) pip install matplotlib #(可选)     mac系统:command+空格

  • node.js + express搭建服务流程2020-02-07 10:06:00

    1. nodejs安装   参考博客: nodejs安装 https://www.jianshu.com/p/d68e461f585c 2.express安装   参考博客: https://www.cnblogs.com/lpxj-blog/p/10651728.html 3.常用npm命令 npm -v   : list version npm init : 初始化 会根据输入信息生成一个描述项目用的json文件

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有