ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

False coin

2021-05-02 03:36:25  阅读:187  来源: 互联网

标签:right False weight 硬币 int coins coin pan


swust oj 709: False coin(模拟)

题目

The “Gold Bar” bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan. In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded. You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.
image
输入:
The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2< = N< =100 ) and K is the number of weightings fulfilled (1< =K< =100 ). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1< =pi< =N/2 ), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '< ', ' >', or '='. It represents the result of the weighting:
• '< ' means that the weight of coins in the left pan is less than the weight of coins in the right pan,
• '> ' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
• '=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

输出:
Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.
样例输入:

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

样例输出:
3

感想

这道题是我在学习bilibili上北理的ACM讲课专题模拟与暴力看到的,整个题很长,很难有耐心看下去,一个找假币的问题,输入N代表硬币的编号,K代表进行称量的次数,后面每一行第一个数代表左边和右边的硬币个数,比如2 1 2 3 4 < 代表1 2 < 3 4,1 1 4 =代表1 = 4 1 2 5代表2 = 5
思路:
image
先把所有硬币初始化为0,然后 = 的硬币的状态变为1 代表是真硬币,<或者>的称量,需要创建一个lightcoins和heightcoins数组,存放轻硬币和重硬币的次数,遍历N枚硬币,只要硬币的状态为0代表它为判断是否为真硬币,并且lightcoins数组的次数如果和不等式出现次数相等或者heightcoins数组的次数和不等式出现的次数相等时,就输出假币。模拟题,未涉及到一些算法和数据结构。

c++代码

#include<iostream>
#include<vector> 
using namespace std;
int main()
{
	int n,k;
	while(cin>>n>>k)
	{
		int sum=0;
		vector<int>coins(n+1,0);//硬币状态 1为真硬币,0为未出现,不知道真假的硬币
		vector<int>lightcoins(n+1,0);
		vector<int>heightcoins(n+1,0);
		int num=0;
		for(int i=0;i<k;i++)
		{
			int x;
			cin>>x;
			vector<int>acoins;//存放硬币的编号
			for(int i=0;i<2*x;i++)
			{
				int y;
				cin>>y;
				acoins.push_back(y);
			}
			char c;
			cin>>c;
			if(c=='=')
			{
				for(int j=0;j<2*x;j++)
				{
					coins[acoins[j]]=1;
				}
			}
			else if(c=='<')
			{
				sum++;
				for(int j=0;j<x;j++)
				{
					lightcoins[acoins[j]]++;
				}
				for(int j=x;j<2*x;j++)
				{
					heightcoins[acoins[j]]++;
				}
			}
				else if(c=='>')
			{
				sum++;
				for(int j=x;j<2*x;j++)
				{
					lightcoins[acoins[j]]++;
				}
				for(int j=0;j<x;j++)
				{
					heightcoins[acoins[j]]++;
				}
			}
		}
		int ans=0;
		int ansnum=0;
		for(int i=1;i<=n;i++)
		{
			if(coins[i]==0&&(lightcoins[i]==sum||heightcoins[i]==sum))
			{
				ansnum++;
				ans=i;
			}
		}
		if(ansnum==1)
		{
			cout<<ans<<endl;
		}
		else
		{
			cout<<0<<endl;
		}
	}
}

有问题,欢迎留言告诉我

标签:right,False,weight,硬币,int,coins,coin,pan
来源: https://www.cnblogs.com/SCPC-QACY/p/14725201.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有