ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1061 Dating (20 分)

2021-03-01 23:34:12  阅读:280  来源: 互联网

标签:case 20 1061 str1 int && capital Dating strings


Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm
 

Sample Output:

THU 14:04
 很难受的一道题,有个测试点过不去
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
char v[2];
int main(){
    string str1,str2,str3,str4;
    cin>>str1>>str2>>str3>>str4;
    int len1=str1.size();
    int len2=str2.size();
    int len3=str3.size();
    int len4=str4.size();
    int len12=min(len1,len2);
    int len34=min(len3,len4);
    int t=0;
    for(int i=0;i<len12;i++){
        if(str1[i]==str2[i]){
            if(str1[i]>='A'&&str1[i]<='G'){
                v[0]=str1[i];
                t=i;
                break;
            }
        }
    }
    for(int i=t+1;i<len12;i++){
        if(str1[i]==str2[i]){
            if((str1[i]>='A'&&str1[i]<='N')||(str1[i]>='0'&&str1[i]<='9')){
                v[1]=str1[i];
                break;
            }
        }
    }
    int k;
    for(int i=0;i<len34;i++){
        if(str3[i]==str4[i]){
            if(str3[i]>='a'&&str3[i]<='z'){
                k=i;
                break;
            }
        }
    }
    int a=v[0]-'A';
    switch(a){
        case 0 : cout<<"MON"; break;
        case 1 : cout<<"TUE"; break;
        case 2 : cout<<"WED"; break;
        case 3 : cout<<"THU"; break;
        case 4 : cout<<"FRI"; break;
        case 5 : cout<<"SAT"; break;
        case 6 : cout<<"SUN"; break;
    }
    int b;
    if(v[1]>='A'&&v[1]<='Z'){
        b=v[1]-'A';
        b=b+10;
    }
    else{
        b=v[1]-'0';
    }
    cout<<" ";
    printf("%02d:",b);
    printf("%02d\n",k);
    return 0;
}


//THU 14:04
//THU 14:04

 

 

标签:case,20,1061,str1,int,&&,capital,Dating,strings
来源: https://www.cnblogs.com/dreamzj/p/14466646.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有