ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Sudoku POJ - 2676

2021-02-25 20:34:01  阅读:214  来源: 互联网

标签:Sudoku int cells 2676 len next POJ each include


Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
DFS。就是需要狂暴剪枝。
一开始只是写了个判断函数判断某个数填在该位置的可行性,然而会T。
因此需要改写成判断在该位置能填哪个数即可。如果一个都不能填则return。
原本冬训的那个数独题由于空格很多。因此还是会T,这需要用到Dancing Links(明天一定学qwq)。
所以就先做了这道……(但我也t了快3小时岂可修)
AC代码如下:
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int t,len,cnt=1,vis[10],flag,next[81][2],map[15][15],possible_num[81][10];//记录下一个可以填的位置,0为x轴,1为y轴 
char map1[15][15];
int check(int row,int arr){
    int temp=0;
    memset(vis,0,sizeof(vis));
    for(int i=0;i<9;i++){
        vis[map[row][i]]=1;
        vis[map[i][arr]]=1;
    } 
    for(int i=(row/3)*3;i<(row/3)*3+3;i++)
        for(int j=(arr/3)*3;j<(arr/3)*3+3;j++) 
                vis[map[i][j]]=1;
    for(int i=1;i<=9;i++)
        if(!vis[i]){
            temp++;
            possible_num[cnt][temp]=i;
        }
    return temp;
}
void dfs(int x,int y){
    if(flag)
        return;
    int temp=check(x,y);
    if(temp)
        for(int i=1;i<=temp;i++){
            map[x][y]+=possible_num[cnt][i];
            cnt++;
            if(cnt==len+1)
                flag=1;
            else
                dfs(next[cnt-1][0],next[cnt-1][1]);
            if(flag)
                return;
            cnt--;
            map[x][y]=0;
        }
}
int main(){
    scanf("%d",&t);
    while(t--){
        cnt=1,len=0,flag=0;
        memset(next,0,sizeof(next));
        for(int i=0;i<9;i++)
            for(int j=0;j<9;j++){
                cin>>map1[i][j];
                map[i][j]=map1[i][j]-'0';
                if(!map[i][j]){
                    next[len][0]=i;
                    next[len][1]=j;
                    len++;
                }
            }
        dfs(next[0][0],next[0][1]);
        for(int i=0;i<9;i++){
            for(int j=0;j<9;j++)
                printf("%d",map[i][j]);    
            printf("\n");
        }
    }
    return 0;
}

 

 

标签:Sudoku,int,cells,2676,len,next,POJ,each,include
来源: https://www.cnblogs.com/mikku39/p/14449108.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有