ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

【ACM-OJ】《Til the Cows Come Home》C语言

2021-02-15 19:58:53  阅读:217  来源: 互联网

标签:map OJ get int visit ACM C语言 Bessie dis


【ACM-OJ】《Til the Cows Come Home》C语言

题目描述

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

输入

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

输出

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

样例输入

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

样例输出

90

提示

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

AC代码

//
//  main.c
//  Til the Cows Come Home
//
//  Created by HISS on 2020/11/12.
//  Copyright © 2020 HISS. All rights reserved.
//

#include <stdio.h>
#define Max 0x3fffffff

int map[1005][1005];
int dis[1005];

void dijkstra(int n)
{
    int visit[1001] = {0};
    int min, i, j, k;
    visit[1] = 1;
    for(i = 1; i < n; ++ i)
    {
        min = Max;
        k = 1;
        for(j = 1; j <= n; ++ j)
        {
            if(!visit[j] && min > dis[j])
            {
                min = dis[j];
                k = j;
            }
        }
        visit[k] = 1;
        for(j = 1; j <= n; ++ j)
        {
            if(!visit[j] && dis[j] > dis[k] + map[k][j])
                dis[j] = dis[k] + map[k][j];
        }
    }
    printf("%d\n", dis[n]);
}

int main()
{
    int t, n, i, j, from, to, cost;
    while(scanf("%d %d", &t, &n)!=EOF)
    {
        for(i = 1; i <= n; ++ i)
        {
            map[i][i] = 0;
            for(j = 1; j < i; ++ j)
                map[i][j] = map[j][i] = Max;
        }
        for(i = 1; i <= t; ++ i)
        {
            scanf("%d %d %d", &from, &to, &cost);
            //可能有多条路,只记录最短的
            if(cost < map[from][to])
                map[from][to] = map[to][from] = cost;
        }
        for(i = 1; i <= n; ++ i)
            dis[i] = map[1][i];
        dijkstra(n);
    }
}

标签:map,OJ,get,int,visit,ACM,C语言,Bessie,dis
来源: https://blog.csdn.net/weixin_47356269/article/details/113818576

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有