ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

B - Power Strings

2020-08-08 09:03:01  阅读:215  来源: 互联网

标签:string Power int concatenation Input Output include Strings


Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int next[1100000] ;
char str[1100000] ;
void getnext(int len)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||str[i]==str[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
}
int main()
{
    int l , m ;
    while(scanf("%s", str)!=EOF)
    {
        if( str[0] == '.' ) break;
        l = strlen(str);
        getnext(l) ;
        m = next[l];
        //if(整个串是用循环节组成的),(l-m)为最小循环节 
        if( l % (l-m) != 0 )//判断最小循环节会被n整除 
            printf("1\n");
        else
        {
            m = l / ( l-m );
            printf("%d\n", m);
        }
        memset(str,0,sizeof(str));
    }
    return 0;
}

 

标签:string,Power,int,concatenation,Input,Output,include,Strings
来源: https://www.cnblogs.com/csx-zzh/p/13456358.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有