ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

D - Seek the Name, Seek the Fame

2020-08-08 09:02:17  阅读:202  来源: 互联网

标签:little Name prefix suffix include Seek Fame string name


The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5
/*题意:求既匹配字符串前缀又匹配后缀的字符
串的长度
思路:其实next[]数组就表示的是最长的前缀和后缀匹配,
那么只要next[]数组的值不为0的话,
就代表有前后缀匹配,递归下去,
当然整个字符串也符合条件*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 400010;
char s[maxn];
int next[maxn], flag,l1;
void getnext(int l)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<l)
    {
        if(j==-1||s[i]==s[j])
        {
            i++,j++;
            next[i]=j;
        }
        else
            j=next[j];
            /*此时t[j] != t[k] ,
所以就有 next[j+1] < k,
那么求 next[j+1] 就等同于求 t[j] 
往前小于 k 个的字符与
t[k] 前面的字符的最长重合串,
即 t[j-k+1] ~ t[j] 与 t[0] ~ t[k-1] 的最长重合串,
那么就相当于求 next[k]
    }*/
}
void dfs(int x)
{
    if(x==0) return ;
    dfs(next[x]);
    if (!flag)
    {
        printf("%d",x);
        flag = 1;
    }
    else printf(" %d",x);
}
int main()
{
    while(~scanf("%s",s))
    {
        int l1=strlen(s);
        getnext(l1);
        flag=0;
        dfs(l1);
        printf("\n");
    }
}

 

标签:little,Name,prefix,suffix,include,Seek,Fame,string,name
来源: https://www.cnblogs.com/csx-zzh/p/13456363.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有