ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

pat 1013

2020-07-18 19:31:54  阅读:373  来源: 互联网

标签:city city1 pat int highways cities repaired 1013


1013 Battle Over Cities (25分)

 

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:给个图,给出k次查询,每次查询给出一个结点,要求判断去掉这个结点之后图是否是连通图,输出使图连通需要添加的边的条数

思路:建图,对于每次查询,dfs算法求图中极大连通子图的个数,输出的结果是子图个数-1

代码如下 :

#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,k;
bool visited[1005]={false};
bool G[1005][1005]={false};
void dfs(int v,int city){
    visited[v]=true;
    for(int i=1;i<=n;i++){
        if(G[v][i]==true){
            if(i!=city&&visited[i]==false){
                dfs(i,city);
            }    
        }
    }
}
void dfsTraverse(int v){
    fill(visited,visited+n+1,false);
    int count=-1;
    for(int i=1;i<=n;i++){
        if(i!=v&&visited[i]==false){
            count++;
            dfs(i,v);
        }
    }
    printf("%d\n",count);
}

int main(){
    scanf("%d%d%d",&n,&m,&k);
    int a,b;
    for(int i=1;i<=m;i++){
        scanf("%d%d",&a,&b);
        G[a][b]=G[b][a]=true;
    }
    int city;
    for(int i=0;i<k;i++){
        scanf("%d",&city);
        dfsTraverse(city);
    }
    return 0;
}

 

标签:city,city1,pat,int,highways,cities,repaired,1013
来源: https://www.cnblogs.com/foodie-nils/p/13337001.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有