ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HDU 胜利大逃亡 (bfs)

2020-07-04 15:42:00  阅读:270  来源: 互联网

标签:HDU now int 城堡 逃亡 Ignatius bfs 魔王 include


题面

gnatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫) 特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output
11

思路

bfs,只不过这题的具体操作需要多一个维度,所以开三维数组就好了。

代码实现

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <string>
#include <vector>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <numeric>
#include<vector>
#include <functional>
using namespace std;
typedef long long ll;
const int N=1000000+10;
int maze[55][55][55];
int moves[6][3]={{1,0,0},{0,0,1},{0,1,0},{-1,0,0},{0,-1,0},{0,0,-1}};
int t,a,b,c,times,flags;
struct node {
   int x,y,z,step;
};
void bfs () {
   flags=0;
   queue<node> q;
   node now,temp;
   now.x=0,now.y=0,now.z=0,now.step=0;
   maze[0][0][0]=1;
   q.push(now);
   while (!q.empty()) {
      now=q.front();
      q.pop();
      if (now.x==a-1&&now.y==b-1&&now.z==c-1) {
         flags=1;
         break;
      }
      else {
         for (int i=0;i<6;i++) {
            int nx=now.x+moves[i][0];
            int ny=now.y+moves[i][1];
            int nz=now.z+moves[i][2];
            temp.x=nx, temp.y=ny, temp.z=nz, temp.step=now.step+1;
            if (nx>=0&&ny>=0&&nz>=0&&nx<a&&ny<b&&nz<c&&maze[nx][ny][nz]==0) {
               if (temp.step+a-1-temp.x+b-1-temp.y+c-1-temp.z>times) {
                  maze[nx][ny][nz]=1;
                  continue;
               }
               q.push (temp);
               maze[nx][ny][nz]=1;
            }
         }
      }
   }
   if (!flags)  cout<<-1<<endl;
   else cout<<now.step<<endl;
}
int main() {
   while (cin>>t) {
      while (t--) {
         cin>>a>>b>>c>>times;
         for (int i=0;i<a;i++) 
          for (int j=0;j<b;j++) 
            for (int k=0;k<c;k++) {
               scanf ("%d",&maze[i][j][k]);
            }
         bfs ();
      }
   }
    return 0;   
}


标签:HDU,now,int,城堡,逃亡,Ignatius,bfs,魔王,include
来源: https://www.cnblogs.com/hhlya/p/13235045.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有