ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Codeup——599 | 问题 A: Speech Patterns (25)

2020-06-30 14:03:21  阅读:254  来源: 互联网

标签:case 25 word 599 text 单词 Patterns input include


题目描述

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

输入

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ‘\n’. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: “Can a can can a can? It can!”

样例输出

can 5

#include <iostream>
#include <string>
#include <map>
#include <cctype>
using namespace std;

int main()
{
	string s,word,result;	//s为句子,word为句子中的单词,result为出现最多的单词
	map<string,int> mp;	//单词数
	map<string,bool> hashTable;	//单词的哈希表
	int i,max;
	while(getline(cin,s)){
		for(i=0;i<s.length();i++){
			if(isalpha(s[i]))	//如果是大写字母则转换成小写字母
				if(isupper(s[i]))
					s[i]=tolower(s[i]);
			if(isalnum(s[i]))	//从句子中获得单词
				word.push_back(s[i]);
			else	//如果是其它符号,说明不是单词,也表示这个单词已经操作过了,将word置空
				word.clear();
			if(!word.empty()&&!isalnum(s[i+1])){	//表示输入的单词完整了,则对其进行操作
				if(hashTable[word]==false){	//该单词首次出现
					mp[word]=1;	
					hashTable[word]=true;
				}
				else	//该单词曾经出现,则将其数量直接加1即可
					mp[word]++;
			}
		}
		max=0;
		for(map<string,int>::iterator it=mp.begin();it!=mp.end();it++)
			if(it->second>max){	//找到单词数出现最多的那一个
				result=it->first;
				max=it->second;
			}
		cout <<result<<" "<<max<<endl;
	}	
	return 0;
} 

标签:case,25,word,599,text,单词,Patterns,input,include
来源: https://blog.csdn.net/qq_44888152/article/details/107007291

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有