标签:25 include city int Over 查集 highways Battle cities
1013 Battle Over Cities (25分)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
简易并查集,并查集详细介绍参考以下博文:
https://blog.csdn.net/PriestessofBirth/article/details/79324937
/*
简易并查集,并查集详细介绍参考以下博文:
https://blog.csdn.net/PriestessofBirth/article/details/79324937
*/
#include<iostream>
#include<string>
#include<vector>
using namespace std;
int a[1005];
int n,m,k,x,y;
struct node{
int from;
int to;
}temp;
vector<node>v;
void init(){
for(int i = 0;i <= n;i++){
a[i] = i;
}
}
int find(int x){
if(x == a[x]){
return x;
}
return a[x] = find(a[x]);
}
void merge(int x,int y){
x = find(a[x]);
y = find(a[y]);
if(x != y){
a[x] = a[y];
}
}
int main(){
// freopen("input.txt","r",stdin);
scanf("%d%d%d",&n,&m,&k);
for(int i = 0;i < m;i++){
scanf("%d%d",&temp.from,&temp.to);
v.push_back(temp);
}
for(int i = 0;i < k;i++){
init();
int l;
scanf("%d",&l);
for(int j = 0;j < m;j++){
if(v[j].from!=l&&v[j].to!=l){
merge(v[j].from,v[j].to);
}
}
int cnt = 0;
for(int j = 1;j <= n;j++){
// printf("%d ",a[j]);
if(j == a[j]&&j!=l){
cnt++;
}
}
printf("%d\n",cnt-1);
}
return 0;
}

标签:25,include,city,int,Over,查集,highways,Battle,cities 来源: https://blog.csdn.net/PriestessofBirth/article/details/104353451
本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享; 2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关; 3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关; 4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除; 5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。