ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Piggy-Bank

2020-02-02 20:02:06  阅读:286  来源: 互联网

标签:Bank int money coins amount Piggy bank piggy


Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

完全背包,找最小值,把dp数组初始化成除了第一位都是99999999,然后用min建立背包,最后如果结果还是99999999,输出不可能

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
using namespace std;

int min(int a, int b) {
    return a < b ? a : b;
}

int main()
{
    int t;
    cin >> t;
    while (t--) {
        int e, f;
        cin >> e >> f;
        f -= e;
        int n;
        cin >> n;
        int cost[501] = { 0 };
        int value[501] = { 0 };
        for (int i = 0; i < n; i++) {
            cin >> value[i] >> cost[i];
        }
        int pos[10001] = { 0 };
        for (int i = 1; i <= f; i++) {
            pos[i] = 99999999;
        }
        for (int i = 0; i < n; i++) {
            for (int j = cost[i]; j <= f; j++) {
                pos[j] = min(pos[j], pos[j - cost[i]] + value[i]);
            }
        }
        if (pos[f] == 99999999) {
            cout << "This is impossible." << endl;
        }
        else {
            cout << "The minimum amount of money in the piggy-bank is " << pos[f] << "." << endl;
        }

    }

    return 0;
}

 

标签:Bank,int,money,coins,amount,Piggy,bank,piggy
来源: https://www.cnblogs.com/Vetsama/p/12253418.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有