ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

next_permutation的使用-Hdu1027

2020-01-30 18:04:13  阅读:276  来源: 互联网

标签:will feng5166 sequence int number next Hdu1027 permutation Princess


Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14475    Accepted Submission(s): 8296


Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?  

 

Input The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.  

 

Output For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.  

 

Sample Input 6 4 11 8  

 

Sample Output 1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10   理解题意: 第一个数是从1-N一共有这么几个数,然后是把这几个数全排列,输出第二个数打的排序   解题思路: 用next_permutation()实现全排列,在输出   代码:
#include <bits/stdc++.h>

using namespace std;

int a[1001];

int main()
{
    int n,m;
    while(cin>>n>>m){
        for(int i = 1;i <= n; i++)
            a[i] = i;
        int b = 1;
        do{
            if(b==m)
                break;
            b++;
        }while(next_permutation(a+1,a+n+1));
        for(int i = 1;i < n; i++)
            cout<<a[i]<<" ";
        cout<<a[n]<<endl;
    }
    return 0;
}

 

标签:will,feng5166,sequence,int,number,next,Hdu1027,permutation,Princess
来源: https://www.cnblogs.com/jingshixin/p/12241799.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有