ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Hello Kiki HDU - 3579(扩展中国剩余定理)

2019-09-18 11:41:31  阅读:294  来源: 互联网

标签:HDU counting 3579 LL coins a0 Kiki m0 include


 One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting. 

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
Sample Input

2
2
14 57
5 56
5
19 54 40 24 80
11 2 36 20 76

Sample Output

Case 1: 341
Case 2: 5996
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <math.h>
using namespace std;
typedef long long LL;
const int N = 1000;
int n;
LL mm[N],aa[N];///模数为m,余数为a, X % m = a
LL extend_gcd(LL a,LL b,LL &x,LL &y)
{
    if(b==0)
    {
        x=1,y=0;
        return a;
    }
    else
    {
        LL x1,y1;
        LL d = extend_gcd(b,a%b,x1,y1);
        x = y1;
        y = x1-a/b*y1;
        return d;
    }
}

LL solve(LL &m0,LL &a0)
{
	
    for(int i = 0; i < n; i++){
    LL m=mm[i];LL a=aa[i];	
    long long y,x;
    LL g = extend_gcd(m0,m,x,y);
    LL t = a-a0>0?a-a0:a0-a;
    if( t%g )return -1;
    x *= (a - a0)/g;
    x %= m/g;
    a0 = (x*m0 + a0);
    m0 *= m/g;
    a0 %= m0;
    if( a0 <0 )a0 += m0;
	}
    return (a0+m0)%m0?(a0+m0)%m0:m0;	
}
/**
* 无解返回false,有解返回true;
* 解的形式最后为 a0 + m0 * t (0<=a0<m0)
*/


int main()
{

    int t;
    scanf("%d",&t);
    int ct=1;
    while(t--)
    {

    	scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&mm[i]);
        }
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&aa[i]);
        }
        LL m0=1,a0=0,falg=1;
        LL x = solve(m0,a0);
     	printf("Case %d: ",ct++); 	       
        if(x<0) printf("-1\n");
        else
        {	
            printf("%lld\n",x);
        }
    }
    return 0;
}

标签:HDU,counting,3579,LL,coins,a0,Kiki,m0,include
来源: https://blog.csdn.net/weixin_43806345/article/details/100977140

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有