ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

【Aizu ALDS1_1_D --- Maximum Profit】

2019-09-13 15:37:02  阅读:335  来源: 互联网

标签:Rt arr yen Profit dollar ALDS1 int Aizu


【Aizu ALDS1_1_D --- Maximum Profit】


Description

You can obtain profits from foreign exchange margin transactions. For example, if you buy 1000 dollar at a rate of 100 yen per dollar, and sell them at a rate of 108 yen per dollar, you can obtain (108 - 100) × 1000 = 8000 yen.

Write a program which reads values of a currency Rt at a certain time t (t=0,1,2,…n−1), and reports the maximum value of Rj−Ri where j>i .

Input

The first line contains an integer n. In the following n lines, Rt (t=0,1,2,…n−1) are given in order.

2≤n≤200,000
1≤Rt≤109

Output

Print the maximum value in a line.

Sample Input

6
5
3
1
3
4
3

Sample Output

3

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
#define MAXN 200010
int arr[MAXN];

int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    int n;
    cin >> n;
    for(int i=0;i<n;i++)
        cin >> arr[i];
    
    int minn = arr[0];
    int maxx = -0x3f3f3f3f;
    for(int i=1;i<n;i++)
    {
        maxx=max(maxx,arr[i]-minn);
        minn=min(arr[i],minn);
    }
    cout << maxx << endl;
    return 0;
}

标签:Rt,arr,yen,Profit,dollar,ALDS1,int,Aizu
来源: https://blog.csdn.net/qq_41879343/article/details/100803600

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有