ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

[hdu5584]LCM Walk

2019-09-04 10:41:25  阅读:369  来源: 互联网

标签:lcm nk hdu5584 mk Walk his grid ey LCM


Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)

Problem Description
A frog has just learned some number theory, and can’t wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!

Input
First line contains an integer T, which indicates the number of test cases.
Every test case contains two integers ex and ey, which is the destination grid.

1T10001≤T≤10001≤T≤1000.
1ex,ey1091≤ex,ey≤10^91≤ex,ey≤109.

Output
For every test case, you should output “Case #x: y”, where x indicates the case number and counts from 1 and y is the number of possible starting grids.

Sample Input

3
6 10
6 8
2 8

Sample Output

Case #1: 1
Case #2: 2
Case #3: 3

题意:
给定一个走路规则,如果你当前在(x,y)那么你接下来可以走到(x+lcm(x,y),y)或者(x,y+lcm(x,y))
lcm(x,y)是x,y的最小公倍数。
然后给你终点,要求所有合法的起点的个数

题解:
我们来假设gcd(x,y)=kgcd(x,y)=kgcd(x,y)=k
x=nk,y=mk,lcm(x,y)=nmkx=nk,y=mk,lcm(x,y)=nmkx=nk,y=mk,lcm(x,y)=nmk
然后(nk,mk)(nk,mk)(nk,mk)的下一步就是(n(m+1)k,mk)(n(m+1)k,mk)(n(m+1)k,mk)或者(nk,m(n+1)k)(nk,m(n+1)k)(nk,m(n+1)k)
那么对于每个(x,y)来说,都是逆推一次的事情。要么是x/=(y+1)【x>y】要么是y/=(x+1)【y>x】
路径是唯一的0.0

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int x,y;
int w33ha(int CASE){
    scanf("%d%d",&x,&y);
    int cnt=1;
    if(x<y)swap(x,y);
    int t=__gcd(x,y);
    while(x%(y+t)==0){
        ++cnt;
        x=x/(y/t+1);
        if(x<y)swap(x,y);
    }
    printf("Case #%d: %d\n",CASE,cnt);
    return 0;
}
int main(){
    int T;scanf("%d",&T);
    for(int i=1;i<=T;i++)w33ha(i);
    return 0;
}

标签:lcm,nk,hdu5584,mk,Walk,his,grid,ey,LCM
来源: https://blog.csdn.net/dxyinme/article/details/100533354

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有