ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Android Studio升级3.5之后buildOutput.apkData must not be null的问题解决

2019-08-28 11:04:43  阅读:159  来源: 互联网

标签:EarlySyncBuildOutput buildOutput Sequences kotlin sequences SequencesKt 3.5 Stud



其实每次Android Studio版本升级都有坑,抱着尝鲜的心态今天把AS升级到3.5之后,在使用Build => Generate Signed APK打包的时候,出现了一个错误:

Caused by: java.lang.IllegalStateException: buildOutput.apkData must not be null
    at com.android.build.gradle.internal.ide.EarlySyncBuildOutput$Companion$load$2.invoke(EarlySyncBuildOutput.kt:103)
    at com.android.build.gradle.internal.ide.EarlySyncBuildOutput$Companion$load$2.invoke(EarlySyncBuildOutput.kt:67)
    at kotlin.sequences.TransformingSequence$iterator$1.next(Sequences.kt:172)
    at kotlin.sequences.SequencesKt___SequencesKt.toCollection(_Sequences.kt:702)
    at kotlin.sequences.SequencesKt___SequencesKt.toMutableList(_Sequences.kt:732)
    at kotlin.sequences.SequencesKt___SequencesKt.toList(_Sequences.kt:723)
 

用 Clean Project 和 Rebuild Project的方法都没有用,后来找到了一个解决方法,记录如下:

先打包一个debug包,然后再生成release包就可以了

 

至于什么原因还没有搞清楚,难道是打包需要先打debug包生成某些配置信息?

 

 



标签:EarlySyncBuildOutput,buildOutput,Sequences,kotlin,sequences,SequencesKt,3.5,Stud

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有