ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

POJ 2386 Lake Counting

2019-07-21 11:43:10  阅读:256  来源: 互联网

标签:map John .. int Lake WW POJ Farmer Counting


Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has. 

Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them. 

Output
* Line 1: The number of ponds in Farmer John’s field.
Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side. 

AC代码:

//poj-2386-Lake counting(八连通)
#include<iostream>
#include<cstdio>
using namespace std;
#define N 100
int n,m;
char map[N][N];
void dfs(int x,int y){
	map[x][y]='.';
	for(int dx=-1;dx<=1;dx++)
		for(int dy=-1;dy<=1;dy++)
		{
			int nx=dx+x;
			int ny=dy+y;
			if(nx>=0&&nx<n&&ny>=0&&ny<m&&map[nx][ny]=='W') 
				dfs(nx,ny);
		}
	return;
}
int main(){
	scanf("%d%d",&n,&m);
	int ans=0;
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	cin>>map[i][j];
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	{
		if(map[i][j]=='W'){
			dfs(i,j);
			ans++; //遍历一遍,计算加一
		}
	}
	printf("%d\n",ans);
	return 0;
}

标签:map,John,..,int,Lake,WW,POJ,Farmer,Counting
来源: https://blog.csdn.net/ljxzuishuai/article/details/96704622

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有