ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

SDNU 1108.Happy luguans(水题)

2019-06-03 20:51:15  阅读:283  来源: 互联网

标签:水题 luguan sequence int luguans SDNU Happy line happy


Description

A sequence of n > 0 integers is called a happy luguan if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3

is a happy luguan, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a happy luguan. You are to write a program to determine whether or not each of a number of sequences is a happy luguan.

Input

Each line of input contains an integer n <= 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying "Happy luguan" or "Not happy luguan".

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Happy luguan
Not happy luguan

Source

SDNU ACM-ICPC 2012 Training Weekly Contest(Freshman/12-16)
#include<bits/stdc++.h>
using namespace std;

int n, a[10000+8];

int main()
{
    while(~scanf("%d", &n) && n != 0)
    {
        bool flag = 1;
        for(int i = 0; i<n; i++)
            scanf("%d", &a[i]);
        for(int i = 0; i<n-1; i++)
        {
            int number = abs(a[i]-a[i+1]);
            if(number>0 && number<n)continue;
            else
            {
                flag = 0;
                break;
            }
        }
        if(flag)printf("Happy luguan\n");
        else printf("Not happy luguan\n");
    }
    return 0;
}

 

标签:水题,luguan,sequence,int,luguans,SDNU,Happy,line,happy
来源: https://www.cnblogs.com/RootVount/p/10969909.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有