ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1062 Talent and Virtue

2019-04-30 13:55:09  阅读:249  来源: 互联网

标签:Talent vg int 1062 Virtue 90 tg 80 total


1062 Talent and Virtue (25 分)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10​5​​), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

解析:

分组排序:

vg,tg >= L 的才进入排序

vg.tg >= H的圣人

tg<H vg>=H的君子

tg<H,vg<H,vg>=vt的小人

剩下的君子。

然后再内部排序按总成绩,vg,id的顺序进行排序。

#include<bits/stdc++.h>
#include<cstring>
#include<string>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b) {
	return b?gcd(b,a%b):a;
}

int n,l,h;
struct node {
	int id;
	int vg;
	int tg;
	int total;
	int r;
};
vector <node> ans;

bool cmp(node n1,node n2) {
	if(n1.r != n2.r)
		return n1.r < n2.r;
	else if(n1.total != n2.total)
		return n1.total > n2.total;
	else if(n1.vg != n2.vg)
		return n1.vg > n2.vg;
	else
		return n1.id < n2.id;
}
int main()
{
	scanf("%d%d%d",&n,&l,&h);
	node t;
	for(int i =0 ; i < n ; i++) {
		scanf("%d%d%d",&t.id,&t.vg,&t.tg);
		if(t.tg >= l && t.vg >= l) {
			t.total = t.tg + t.vg;
			if(t.tg >= h && t.vg >= h)
				t.r = 1;
			else if(t.tg <h && t.vg >= h)
				t.r = 2;
			else if(t.tg < h && t.vg < h && t.vg >= t.tg)
				t.r = 3;
			else
				t.r = 4;

			ans.push_back(t);
		}
	}

	sort(ans.begin(),ans.end(),cmp);

	printf("%d\n",ans.size());
	for(int i = 0 ; i < ans.size(); i++)
		printf("%d %d %d\n",ans[i].id,ans[i].vg,ans[i].tg);


	return 0;
}

 

 

标签:Talent,vg,int,1062,Virtue,90,tg,80,total
来源: https://blog.csdn.net/yu121380/article/details/89707698

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有