ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

安装 VPrix Desktop 的系统要求

2024-05-03 22:31:17  阅读:167  来源: 互联网

标签:


VPrix Desktop可以运行在单服务器上,也可以运行在多服务器上, 它是由一组服务组成的系统.

操作系统

VPrix服务和用户的桌面会话,都是运行在Docker容器中,依赖于操作系统的Docker组件. 支持的操作系统

操作系统 版本
Ubuntu 18.04 / 20.04 / 22.04 (amd64/arm64)
Debian 10 / 11 / 12 (amd64/arm64)
CentOS 7 / 8 / 9 (amd64/arm64)

并非所有已发布的镜像在以上操作系统都可用,更多详情,请参考 VPrix Image

所需资源

最低资源需求

资源类型 数量
CPU 2核
内存 4GB
硬盘空间 50GB

虽然对 Vprix 服务的需求很低,但用户在使用虚拟桌面会话时需要更多的计算资源。

默认的 VPrix Desktop 配置需要 2768MB 内存和 2 个内核。此外,存储要求取决于您需要安装的应用镜像。如果 Docker 的存储目录(默认为 /var/lib/docker)中没有足够的可用空间,可能会导致安装失败或出现异常行为。

因此,请检查主机操作系统的分区布局,以确保满足这一要求。在使用自定义桌面镜像时,存储需求可能会有所不同。

交换分区Swap

管理员可以在后台为每个会话设置任意数量的CPU内存,但是,即使给了虚拟桌面会话充足的内存,也不能保证在不启动交换分区Swap情况下不出现稳定性问题,比如VSCodeChrome就默认需要启动swap.

因此,我们建议在安装的时候启动交换分区Swap.

安装 Swap 分区可以让虚拟桌面会话获得最佳稳定性。有关 docker 资源约束的其他详细信息 请参阅以下链接:Docker 资源约束

创建交换分区

在安装过程中,如果不存在交换分区,系统将提示用户创建交换分区。

$ sudo bash vprix_release/install.sh --swap-size 8192

这将在 VPrix Desktop 安装期间创建一个 8GB 的交换分区.

有关交换分区的详细信息,请查看 Ubuntu 文档

Docker和Docker Compose版本

在安装过程中,如果计算机上不存在DockerDocker Compose,则安装程序将安装已知的兼容版, 但是,如果这些程序已经存在, 安装程序不会替换它们. 建议您将 VPrix 安装在单一用途的机器上,并让安装程序安装Docker 和 Docker Compose程序。

以下是最低的版本要求:

资源类型 版本
Docker > 18.06
Docker Compose > 2.1.1

运行以下命令检查版本:

$ sudo docker --version
$ sudo docker info | grep "Docker Compose"

用户浏览器版本要求

用户通过 Web UI 访问 VPrix Desktop。我们支持大多数现代浏览器。

浏览器 版本
Chrome 66+
Edge 80+
Firefox 58+
Safari 14+

Tips:

  1. 移动端浏览器不支持音频。
  2. 无缝剪贴板(在不使用控制面板的情况下复制和粘贴)仅在基于 Chrome 和 Chromium 的客户端浏览器上受支持。

标签:
来源:

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有