ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT Advanced 1032 Sharing(25)

2022-09-06 21:01:17  阅读:200  来源: 互联网

标签:node 25 Sharing no next 链表 v1 1032 position


题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

image

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).
Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.
Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

算法描述:链表 结构体

题目大意:

求两个链表的首个共同结点的地址。如果没有,就输出-1

#include<iostream>
#include<vector>
using namespace std;

struct node{ // 静态链表  不需要指针
    char data;
    int next;
};
node no[100010];

int main()
{
    int h1, h2, n, addr, i, j;
    cin >> h1 >> h2 >> n;
    
    while(n --)
    {
        cin >> addr;
        cin >> no[addr].data >> no[addr].next;
    }
    
    vector<int> v1, v2;
    for(i = h1 ; i != -1 ; i = no[i].next)
        v1.push_back(i);

    for(i = h2 ; i != -1 ; i = no[i].next)
        v2.push_back(i);
    // 从后往前遍历两链表,直至两链表元素不同
    for(i = v1.size() - 1, j = v2.size() - 1 ; i >= 0 && j >= 0 && v1[i] == v2[j] ; i --, j --);
    // 没有共同后缀
    if(i == v1.size() - 1)    cout << -1;
    else    printf("%05d", v1[i + 1]);
    return 0;
}

标签:node,25,Sharing,no,next,链表,v1,1032,position
来源: https://www.cnblogs.com/yztozju/p/16663284.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有