ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT_A 1037 Magic Coupon

2022-09-04 23:31:52  阅读:172  来源: 互联网

标签:product PAT get Coupon back coupon int Magic line


PAT_A 1037 Magic Coupon

分析

尽量增大总回报值即可得到结果。

PAT_A 1037 Magic Coupon

题目的描述

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N**C, followed by a line with N**C coupon integers. Then the next line contains the number of products N**P, followed by a line with N**P product values. Here 1≤N**C,N**P≤\(10^5\), and it is guaranteed that all the numbers will not exceed$ 2^30$.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

AC的代码

#include<bits/stdc++.h>

using namespace std;

bool cmp(int a,int b){
    return a>b;
}

int main(){
    int NC,NP;
    scanf("%d",&NC);
    vector<int> C(NC);
    for(int i=0;i<NC;i++){
        scanf("%d",&C[i]);
    }
    
    scanf("%d",&NP);
    vector<int> P(NP);
    for(int i=0;i<NP;i++){
        scanf("%d",&P[i]);
    }
    sort(C.begin(),C.end(),cmp);
    sort(P.begin(),P.end(),cmp);
    long long totlareward = 0;
    for(int i=0, j=0;i<NC&&j<NP&&C[i]>0&&P[j]>0;j++,i++){

        totlareward += C[i]*P[j];

    }
    for(int i=NC-1, j=NP-1;i>-1&&j>-1&&C[i]<0&&P[j]<0;i--,j--){

        totlareward += C[i]*P[j];


    }
    printf("%lld\n",totlareward);
    return 0;
}

标签:product,PAT,get,Coupon,back,coupon,int,Magic,line
来源: https://www.cnblogs.com/ghosteq/p/16656505.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有