ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT Advanced 1029 Median(25)

2022-08-28 23:03:24  阅读:179  来源: 互联网

标签:integers PAT sequence int 1029 Median median sequences n1


题目描述:

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

算法描述:归并排序

题目大意:

给出两个序列,求两序列的中间值

#include<iostream>
#include<algorithm>
using namespace std;

int n1, n2, a[1000010];

int main()
{
    cin >> n1;
    for(int i = 0 ; i < n1 ; i ++)  scanf("%d", &a[i]);
    cin >> n2;
    for(int i = 0 ; i < n2 ; i ++)  scanf("%d", &a[n1 + i]);
    sort(a, a + n1 + n2);
    cout << a[(n1 + n2 - 1) / 2];
}

标签:integers,PAT,sequence,int,1029,Median,median,sequences,n1
来源: https://www.cnblogs.com/yztozju/p/16634349.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有