ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

【POJ1258】Agri-Net(最小生成树prim,简单,请别忘记多组输入谢谢)

2019-03-14 19:52:39  阅读:284  来源: 互联网

标签:POJ1258 his prim farm farms fiber connect Agri include


Agri-Net

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 71567   Accepted: 29652

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms. 

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


 

我真蠢,总是忘记多组输入。。。 

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#define go(i,a,b) for(int i=a;i<=b;i++)
#define og(i,a,b) for(int i=a;i>=b;i--)
#define mem(a) memset(a,0,sizeof(a))
#define cs cout<<"-----"<<endl;
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn = 1e3 + 10;
const double pi = atan(1.)*4;
typedef long long ll;
int G[maxn][maxn],dis[maxn],vis[maxn];
int n,pos,sum;
int prim()
{
    mem(vis);
    vis[1]= 1;
    pos = 1;
    for(int i = 1;i <= n;i++)
        if(i!=pos)  dis[i] = G[pos][i];
    for(int i =1;i <n;i++)
    {
        int minl =inf;
        for(int j = 1;j <= n;j++)
        {
            if(!vis[j] && dis[j] < minl)
            {
                minl =dis[j];
                pos = j;
            }
        }
        sum +=minl;
        vis[pos] = 1;
        for(int j =1;j <=n;j++)
            if(!vis[j] && G[pos][j] < dis[j])   dis[j] =G[pos][j];
    }
    return sum;
}
int main()
{
    while(cin>>n)
    {
        sum = 0;
        mem(G);
        for(int i=1;i <= n;i++)
            for(int j = 1;j <= n;j++)
                cin>>G[i][j];
        prim();
        cout<<sum<<endl;
    }
    return 0;
}

 

标签:POJ1258,his,prim,farm,farms,fiber,connect,Agri,include
来源: https://blog.csdn.net/hzyhfxt/article/details/88559344

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有