标签:25 结点 city int Over highways maxn Battle cities
1013 Battle Over Cities (25 分)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input:
3 2 3
1 2
1 3
1 2 3
Sample Output:
1
0
0
题意: 给定一个无向图,当删除图中某个结点时,将会把与之相连的边删除,给出k个查询,每个查询给出对应的结点编号,求删除该顶点后需要多少条边才能使图变得连通。
思路:1添加的边数等于连通块个数减1,故题目要求的是连通块的个数。
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=1010;
const int INF=99999999;
int G[maxn][maxn];
bool vis[maxn];
int deletepoint,n;
void dfs(int v)
{
if(v==deletepoint){//如果当前结点等于要删除的结点,则return
return ;
}
vis[v]=true;
for(int i=1;i<=n;i++){//从1开始
if(vis[i]==false&&G[v][i]==1){
dfs(i);
}
}
}
int main()
{
int m,k,u,v,num;
scanf("%d %d %d",&n,&m,&k);
fill(G[0],G[0]+1010*1010,INF);
for(int i=0;i<m;i++){
scanf("%d %d",&u,&v);
G[u][v]=G[v][u]=1;
}
for(int i=0;i<k;i++){
num=0;
scanf("%d",&deletepoint);
fill(vis,vis+1010,false);
for(int j=1;j<=n;j++){//从1开始
if(j!=deletepoint&&vis[j]==false){//要判断是否之前的循环遍历过了
dfs(j);
num++;//放if里面,放外面的话记的是结点的个数
}
}
printf("%d\n",num-1);
}
return 0;
}
标签:25,结点,city,int,Over,highways,maxn,Battle,cities 来源: https://blog.csdn.net/weixin_42105789/article/details/88423194
本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享; 2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关; 3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关; 4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除; 5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。