ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1072. Gas Station (30)(Dijkstra)

2022-02-16 23:00:38  阅读:249  来源: 互联网

标签:G1 int MAXV Gas 加油站 Dijkstra Station city2 city1


A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

题目大意:

从m个加油站里面选取1个站点,让他离居民区的最近的人最远,并且没有超出服务范围ds之内。如果有很多个最远的加油站,输出距离所有居民区距离平均值最小的那个。如果平均值还是一样,就输出按照顺序排列加油站编号最小的那个

分析:

因为加油站之间也是彼此有路连接的,所以最短路径计算的时候也要把加油站算上。所以我们就是对n+m个点进行Dijkstra计算最短路径。要求计算出1~m号加油站距离其他站点的最短路径。这时候可以遍历dis数组,如果dis存在一个距离大于服务范围ds的距离,那么我们就舍弃这个加油站。取最最短的路径,这就是距离它最近的加油站mindis。如果mindis > ansdis,就是说找到了一个距离居民最小距离的加油站是更远的,那就选这个加油站,更新ansid为它的id。最后输出
对于加油站的字符串编号的处理:如果最近居民区最大的值没有变化但是找到了一个更小的平均距离,那就选这个。我们可以根据输入的是G还是数字,如果是数字就令编号为他自己,如果是G开头的,编号设为n+G后面的数字。
Update:Github用户littlesevenmo在issue中提出需要添加输入判断,题目中并没有说明两点之间最多只有一条路。也就是说,有可能两点之间有多条路,因此需要添加判断,只存储距离最短的路。另外,也有可能会出现 G1 G1 9999这样的测试数据,因此,自身与自身之间的距离要初始化为0。完善后的代码如下:
原文链接:https://blog.csdn.net/liuchuo/article/details/52317022

题解

image
image
image

#include <bits/stdc++.h>

using namespace std;
const int MAXV=1020;
const int INF=1000000000;

int n,m,k,ds,G[MAXV][MAXV];
int d[MAXV];
bool vis[MAXV];

void Dijkstra(int s)
{
    memset(vis,false,sizeof(vis));
    fill(d,d+MAXV,INF);
    d[s]=0;
    for(int i=0;i<n+m;i++){
        int u=-1,MIN=INF;
        for(int j=1;j<=n+m;j++){
            if(vis[j]==false&&d[j]<MIN){
                u=j;
                MIN=d[j];
            }
        }
        if(u==-1) return;
        vis[u]=true;
        for(int v=1;v<=n+m;v++){
            if(vis[v]==false&&G[u][v]!=INF){
                if(d[u]+G[u][v]<d[v]){
                    d[v]=d[u]+G[u][v];
                }
            }
        }
    }
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    cin>>n>>m>>k>>ds;
    int u,v,w;
    fill(G[0],G[0]+MAXV*MAXV,INF);
    string city1,city2;
    for(int i=0;i<k;i++){
        cin>>city1>>city2>>w;
        if(city1[0]=='G'){
            city1=city1.substr(1);
            u=n+stoi(city1);
        }else u=stoi(city1);
        if(city2[0]=='G'){
            city2=city2.substr(1);
            v=n+stoi(city2);
        }else v=stoi(city2);
        G[v][u]=G[u][v]=w;
    }
    double ansDis=-1,ansAvg=INF;
    int ansID=-1;
    for(int i=n+1;i<=n+m;i++){
        double minDis=INF,avg=0;
        Dijkstra(i);
        for(int j=1;j<=n;j++){
            if(d[j]>ds){
                minDis=-1;
                break;
            }
            if(d[j]<minDis) minDis=d[j];
            avg+=1.0*d[j]/n;
        }
        if(minDis==-1) continue;
        if(minDis>ansDis){
            ansID=i;
            ansDis=minDis;
            ansAvg=avg;
        }else if(minDis==ansDis&&avg<ansAvg){
            ansID=i;
            ansAvg=avg;
        }
    }
    if(ansID==-1) cout<<"No Solution"<<endl;
    else{
        printf("G%d\n",ansID-n);
        printf("%.1f %.1f\n",ansDis,ansAvg);
    }
    return 0;
}

标签:G1,int,MAXV,Gas,加油站,Dijkstra,Station,city2,city1
来源: https://www.cnblogs.com/moonlight1999/p/15902718.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有