ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1102 Invert a Binary Tree (25 分)(树的遍历)

2022-01-14 18:04:00  阅读:178  来源: 互联网

标签:node Binary 结点 25 int Invert rchild now root


The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree — and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 –
– –
0 –
2 7
– –
– –
5 –
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

生词

英文 解释
indices index的复数

题目大意:

反转一棵二叉树,给出原二叉树的每个结点的左右孩子,输出它的层序和中序遍历~

分析:

  1. 反转二叉树就是存储的时候所有左右结点都交换。
  2. 二叉树使用{id, l, r, index, level}存储每个结点的id, 左右结点,下标值,和当前层数~
  3. 根结点是所有左右结点中没有出现的那个结点~
  4. 已知根结点,用递归的方法可以把中序遍历的结果push_back到数组v1里面,直接输出就是中序,排序输出就是层序(排序方式,层数小的排前面,相同层数时,index大的排前面)

原文链接:https://blog.csdn.net/liuchuo/article/details/52175736

题解

image
image

#include <bits/stdc++.h>

using namespace std;
const int maxn=110;
struct Node
{
    int lchild,rchild;
}node[maxn];
bool notRoot[maxn];
int n,num=0;

int strToNum(char c){
    if(c=='-') return -1;
    else{
        notRoot[c-'0']=true;
        return c-'0';
    }
}
int findRoot(){
    for(int i=0;i<n;i++){
        if(notRoot[i]==false)
            return i;
    }
}
void print(int id){
    cout<<id;
    num++;
    if(num<n) cout<<" ";
    else cout<<endl;
}
void postOrder(int root){
    if(root==-1) return;
    postOrder(node[root].lchild);
    postOrder(node[root].rchild);
    swap(node[root].lchild,node[root].rchild);
}
void BFS(int root){
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int now=q.front();
        q.pop();
        print(now);
        if(node[now].lchild!=-1) q.push(node[now].lchild);
        if(node[now].rchild!=-1) q.push(node[now].rchild);
    }
}
void inOrder(int root){
    if(root==-1) return;
    inOrder(node[root].lchild);
    print(root);
    inOrder(node[root].rchild);
}

int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    char lchild,rchild;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        //getchar();
        scanf("%*c%c %c",&lchild,&rchild);
        node[i].lchild=strToNum(lchild);
        node[i].rchild=strToNum(rchild);
    }
    int root=findRoot();
    postOrder(root);
    BFS(root);
    num=0;
    inOrder(root);
    return 0;
}

标签:node,Binary,结点,25,int,Invert,rchild,now,root
来源: https://www.cnblogs.com/moonlight1999/p/15802876.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有