ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT (Advanced Level) Practice 1032 Sharing (25 分)

2021-12-18 15:34:30  阅读:180  来源: 互联网

标签:node 25 Sharing PAT int next 67890 word1 ans


To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N ( ≤ 1 0 5 ) N (≤10^5) N(≤105), where the two addresses are the addresses of the first nodes of the two words, and N N N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N N N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

思路

  • 一开始做错的思路: 因为共用节点入度为2,而出度为1, 所以读取数据的时候留心入度为2的点就可以了, 假如-1的入度为2了, 说明有两个尾巴 自然没有公用后缀,直接输出-1

    • 错误的原因是: 题目里没有讲所有的点都在word1word2当中, 也就是存在没有关系的点, 这样的话就会有误, 我们一定要统计属于word1word2这两条链上的
    • 所以很容易想到把所有的点存下来, 遍历一遍word1, 把word1上的点标记为1, 后面遍历word2时有点的状态是1就可以认为在word1中出现过
  • 因为题目表示, 只有相同后缀才会合并使用, 非后缀相同不会合并, 所以只要有一个点是公用的,后面的都是公用的,共同组成共有后缀

AC code

#include<iostream>
using namespace std;
struct Node{
    int next;
    int status = 0;
}node[100005];
int main(){
    int head1,head2,tail,n,x,y;
    int ans=-1;
    char c;
    scanf("%d %d %d",&head1,&head2,&n);
    for(int i=0;i<n;i++){
        scanf("%d %c %d\n",&x,&c,&y);
        node[x].next = y;
    }
    for(int i=head1;i!=-1;i=node[i].next){
        node[i].status = 1;
    }
    for(int i=head2;i!=-1;i=node[i].next){
        if(node[i].status==1){
            ans = i;
            break;
        }
    }
    if(ans==-1) printf("-1");
    else printf("%05d",ans);  
    return 0;
}

标签:node,25,Sharing,PAT,int,next,67890,word1,ans
来源: https://blog.csdn.net/qq_52429637/article/details/122012606

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有