ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Just a Hook

2021-11-17 21:03:19  阅读:198  来源: 互联网

标签:node lazy Just hook int value Hook each


原题链接:https://acm.dingbacode.com/showproblem.php?pid=1698

Problem Description:

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.


Input:

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output:

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.


Sample Input:

1
10
2
1 5 2
5 9 3

Sample Output:

Case 1: The total value of the hook is 24.

解题思路:

线段树模板题,本题包含建树、向上回溯、区间修改、区间查询、向下推

AC代码:

#include<iostream>
using namespace std;
#define n 100000
int T, N, Q;						//测试数据组数T、钩子的钢棒数N、操作Q
int lazy[n * 4];
int tree[n * 4];				        //定义线段树数组
int a, b, level, sum;
void pushup(int node)					//所有父结点的值为子树值的和
{
	tree[node] = tree[node * 2] + tree[node * 2 + 1];
}
void pushdown(int node, int m)
{
	if (lazy[node])
	{
		lazy[node * 2] = lazy[node];
		lazy[node * 2 + 1] = lazy[node];
		tree[node * 2] = lazy[node] * (m - (m / 2));
		tree[node * 2 + 1] = lazy[node] * (m / 2);
		lazy[node] = 0;
	}
}
void build(int l, int r, int node)		      //建树
{
	lazy[node] = 0;
	if (l == r)
	{
		tree[node] = 1;
		return;
	}
	int mid = (l + r) / 2;
	build(l, mid, node * 2);
	build(mid + 1, r, node * 2 + 1);
	pushup(node);
}

void update(int a, int b, int level, int l, int r, int node) 
{                                                //更改区间 更改至c
	if (a <= l && r <= b) {			// l,r 树的区间  
		lazy[node] = level;
		tree[node] = (int)level * (r - l + 1);
		return;
	}
	pushdown(node, r - l + 1);
	int m = (l + r) / 2;
	if (a <= m) {
		update(a, b, level, l, m, node * 2);
	}
	if (b > m) {
		update(a, b, level, m+1, r, node * 2 + 1);
	}
	pushup(node);
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	cin >> T;						//测试数据组数T
	for (int i = 1; i <= T; i++)
	{
		cin >> N;					//钢棒数N
		cin >> Q;					//操作数Q
		build(1, N, 1);
		for (int i = 0; i < Q; i++)
		{
			cin >> a >> b >> level;
			update(a,b,level, 1, N, 1);		//进行钩子升级	
		}
		printf("Case %d: The total value of the hook is %d.\n",i,tree[1]);
	}
	return 0;
}

标签:node,lazy,Just,hook,int,value,Hook,each
来源: https://www.cnblogs.com/baiye-y/p/15569418.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有