ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1028 List Sorting (25 分)(排序)

2021-11-10 10:33:15  阅读:251  来源: 互联网

标签:25 Sorting return name int James List 90 000010


Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

生词

英文 解释
imitate 模仿
sort with 与...相符合
inclusive 包括的

题目大意:

根据c的值是1还是2还是3,对相应的列排序。第一列升序,第二列不降序,第三列不降序

分析:

注意,按照名称的不降序排序,因为strcmp比较的是ACSII码,所以A < Z。写cmp函数的时候return strcmp(a.name, b.name) <= 0; return语句返回的是true或者false的值,所以要写 <= 0 这样的形式。比较ACSII码的大小,strcmp(‘a’, ‘z’)返回负值,因为a<z a – z < 0
按照分数的不降序排序,a.score <= b.score

原文链接:https://blog.csdn.net/liuchuo/article/details/52144549

题解

以前(不知道啥时候做的)做的:

#include<bits/stdc++.h>

using namespace std;
struct student
{
    int id;
    char name[10];
    int grade;
} ;
bool cmp1(student a,student b)
{
    return a.id<b.id;
}
bool cmp2(student a,student b)
{
    if(strcmp(a.name,b.name)!=0)
        return strcmp(a.name,b.name)<=0;
    else
        return a.id<b.id;
}
bool cmp3(student a,student b)
{
    if(a.grade!=b.grade)
        return a.grade<=b.grade;
    else
        return a.id<b.id;
}
int main()
{
    int n,c;
    student stu[100000];
    scanf("%d %d",&n,&c);

    for(int i=0; i<n; i++)
    {
        scanf("%d %s %d",&stu[i].id,stu[i].name,&stu[i].grade);
    }
    if(c==1)
        sort(stu,stu+n,cmp1);
    else if(c==2)
        sort(stu,stu+n,cmp2);
    else
        sort(stu,stu+n,cmp3);
    //printf("Case %d:\n",c);
    for(int i=0; i<n; i++)
        printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].grade);

    return 0;
}

现在做的:

#include <bits/stdc++.h>

using namespace std;
struct student
{
    long int id;
    string name;
    int score;
};
bool cmp1(student a,student b){
    return a.id<b.id;
}
bool cmp2(student a,student b){
    return a.name!=b.name?a.name<b.name:a.id<b.id;
}
bool cmp3(student a,student b){
    return a.score!=b.score?a.score<b.score:a.id<b.id;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,c;
    cin>>n>>c;
    vector<student> v(n);
    for(int i=0;i<n;i++){
        cin>>v[i].id>>v[i].name>>v[i].score;
    }
    if(c==1) sort(v.begin(),v.end(),cmp1);
    else if(c==2) sort(v.begin(),v.end(),cmp2);
    else sort(v.begin(),v.end(),cmp3);
    for(int i=0;i<n;i++)
    {
        printf("%06d %s %d\n",v[i].id,v[i].name.c_str(),v[i].score);
    }
}

柳神做的:

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int maxn = 100001;
struct NODE {
    int no, score;
    char name[10];
}node[maxn];
int c;
int cmp1(NODE a, NODE b) {
    if(c == 1) {
        return a.no < b.no;
    } else if(c == 2) {
        if(strcmp(a.name, b.name) == 0) return a.no < b.no;
        return strcmp(a.name, b.name) <= 0;
    } else {
        if(a.score == b.score) return a.no < b.no;
        return a.score <= b.score;
    }
}
int main() {
    int n;
    scanf("%d%d", &n, &c);
    for(int i = 0; i < n; i++)
        scanf("%d %s %d", &node[i].no, node[i].name, &node[i].score);
    sort(node, node + n, cmp1);
    for(int i = 0; i < n; i++)
        printf("%06d %s %d\n", node[i].no, node[i].name, node[i].score);
    return 0;
}

标签:25,Sorting,return,name,int,James,List,90,000010
来源: https://www.cnblogs.com/moonlight1999/p/15532266.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有