ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1124 Raffle for Weibo Followers (20 分)

2021-10-28 22:34:22  阅读:215  来源: 互联网

标签:Raffle Weibo Imgonnawin 中奖 Followers 中奖者 TryAgainAgain each 顺延


1. 题目

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

2. 题意

John进行转发抽奖活动,给出三位正整数M,N,S,分别表示转发的总人数、小明决定的中奖间隔、以及第一名中奖者的序号(编号从1开始)。每位网友可能多次转发,但只能中一次奖。如果处于当前位置的网友中过奖,则一直顺延到下一位没有中奖的网友。

3. 思路——模拟+map

  1. 如果第1位中奖者的序号大于转发总人数,说明没人中奖,直接输出return 0即可。
  2. 否则从第1位中奖者S开始,每N位产生一名中奖者:如果该名网友先前中奖过,那么就顺延给下一位没有中奖的网友;否则就输出该名中奖者的网名,并将其置为中奖过的状态!
  • 错误总结:
    • 这题我自己因为没有理解对题目意思,所以卡了很久,刚开始题目有点没看懂,这是硬伤,后面看了翻译,又理解错了题目,以为顺延值顺延一位,没有想到顺延那一位如果也中奖过再往下顺延的情况。综上理解,导致卡了很久,题目本身并不难。
    • 还有就是刚开始想到用set来判断网友有没有中奖过,但是这比起使用map麻烦很多,所以选择正确的数据结构很有必要!

4. 代码

#include <iostream>
#include <map>
#include <string>

using namespace std;

int main()
{
	int m, n, s;
	cin >> m >> n >> s;
	map<string, int> res;
	string names[m + 1];
	for (int i = 1; i <= m; ++i) 
		cin >> names[i];
		
	if (s > m) // 如果第一位获胜者的位数大于转发总数,说明没有获胜者 
		cout << "Keep going..." << endl;

	// 从第一位获胜者s开始,每间隔n位产生一名获胜者 
	for (int i = s; i <= m; i += n)
	{
		if (res[names[i]] == 1) // 如果这位获胜者已经拿过一次奖了 
		{ 
			i++;	// 那么开始顺延给下一位 
			while (i <= m)	// 一直顺延,直到没有获奖过之前都没获奖过的那一位 
			{
				if (res[names[i]] == 0)  
				{
					cout << names[i] << endl;
					res[names[i]] = 1; 
					break;
				}
				i++;
			}
		} else	// 如果这位获胜者未获过奖,则输出 
		{
			cout << names[i] << endl;
			res[names[i]] = 1;
		}
	
	}
	return 0;
}

标签:Raffle,Weibo,Imgonnawin,中奖,Followers,中奖者,TryAgainAgain,each,顺延
来源: https://www.cnblogs.com/vanishzeng/p/15478048.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有