ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

pta甲级1032 Sharing(AC)

2021-10-22 20:03:00  阅读:188  来源: 互联网

标签:node AC Sharing int 结点 链表 flag 1032 position


To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

结尾无空行

Sample Output 1:

67890

结尾无空行

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

结尾无空行

Sample Output 2:

-1

结尾无空行

 

思路:
1.建立一个结构体数组,里面包含它存储的字符,和它的下一个结点的地址名,最后设置一个bool类型的flag来判断它是否在第一段链表出现。

2.初始时设置结构体数组的flag都是0,而在第一个链表中出现的结点,使它们的flag都是1,第二次检索第二个链表的结点,对于出现的第一个flag值为1的结点,输出这个结点的下标。

否则,也就是没有这个重合结点的时候,输出-1。

#include<bits/stdc++.h>
using namespace std;
const int maxn=100005;
struct Node{
	char data;
	int next;
	bool flag;
}node[maxn];

int main()
{
	int begin1,begin2,n,address,next1,data1; 
	scanf("%d %d %d",&begin1,&begin2,&n);
	for(int i=1;i<=n;i++){
		scanf("%d %c %d",&address,&data1,&next1);
		node[address].data=data1;
		node[address].next=next1;
		node[address].flag=0;
	}
	int p=-1;
	for(p=begin1;p!=-1;p=node[p].next) node[p].flag=1;
	for(p=begin2;p!=-1;p=node[p].next){
		if(node[p].flag==1) break;
	}
	if(p==-1) printf("-1");
	else printf("%05d",p);
}

这应该算难度比较小的链表了,不是很难。 

搞定!!

标签:node,AC,Sharing,int,结点,链表,flag,1032,position
来源: https://blog.csdn.net/worldinme/article/details/120912355

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有