ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

pta甲级1002 A+B for Polynomials(AC)

2021-10-21 23:00:50  阅读:168  来源: 互联网

标签:case AC int pta each input line where 1002


This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

结尾无空行

Sample Output:

3 2 1.5 1 2.9 0 3.2

结尾无空行

思路:
不能说很简单,只能说完全不要动脑子。

#include<bits/stdc++.h>
using namespace std;
double a[1001][3],b[1001];
int main()
{
	int k,count=0;
	for(int i=1;i<=2;i++){
		cin>>k;
		for(int j=1;j<=k;j++){
			int m;
			cin>>m;
			cin>>a[m][i];
		}
	}
	for(int i=0;i<=1000;i++){
		b[i]=a[i][1]+a[i][2];
		if(b[i]!=0) count++;
	}
	printf("%d",count);
	for(int i=1000;i>=0;i--){
		if(b[i]!=0) printf(" %d %.1lf",i,b[i]);
	}
}

 

 搞定!!

标签:case,AC,int,pta,each,input,line,where,1002
来源: https://blog.csdn.net/worldinme/article/details/120896719

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有