ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1037 Magic Coupon(简单题,sort()排序)

2021-10-05 15:58:39  阅读:192  来源: 互联网

标签:sort tmp begin Magic Coupon 样例 int include


目录

题目

测试样例

输入样例

输出样例

提交结果截图

带详细注释的源代码


题目

题目链接:

1037 Magic Coupon icon-default.png?t=L892https://pintia.cn/problem-sets/994805342720868352/problems/994805451374313472

测试样例

输入样例

4
1 2 4 -1
4
7 6 -2 -3

输出样例

43

提交结果截图

带详细注释的源代码

#include <cstdio>
#include "string.h"
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

//正数从小到大排序
bool cmp1(const int a, const int b)
{
	return a > b;
}

//负数从大到小排序
bool cmp2(const int a, const int b)
{
	return a < b;
}

int main()
{
	vector<int>c_p, c_n, p_p, p_n;//coupon_positive, coupon_negetive, product_positive, product_negetive
	int m, n, tmp, sum = 0;
	cin >> m;
	for (int i = 0; i < m; i++)
	{
		cin >> tmp;
		if (tmp > 0)//不能用if(tmp),因为只有0为假,其他都为真
			c_p.push_back(tmp);
		else
			c_n.push_back(tmp);
	}
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> tmp;
		if (tmp > 0)
			p_p.push_back(tmp);
		else
			p_n.push_back(tmp);
	}
	//排序
	sort(c_p.begin(), c_p.end(), cmp1);
	sort(c_n.begin(), c_n.end(), cmp2);
	sort(p_p.begin(), p_p.end(), cmp1);
	sort(p_n.begin(), p_n.end(), cmp2);
	//先求正乘正
	for (int i = 0, j = 0; i < c_p.size() && j < p_p.size();i++, j++)
		sum += c_p[i] * p_p[j];//cout<<"c_p["<<i<<"]"<< c_p[i]<<", p_p["<<j<<"] = "<< p_p[j]<<endl;

	//再求负乘负
	for (int i = 0, j = 0; i < c_n.size() && j < p_n.size();i++, j++)
		sum += c_n[i] * p_n[j];// cout << "c_n[" << i << "]" << c_n[i] << ", p_n[" << j << "] = " << p_n[j] << endl;
	cout << sum << endl;
	return 0;
}

标签:sort,tmp,begin,Magic,Coupon,样例,int,include
来源: https://blog.csdn.net/NOT_TODAY1/article/details/120614776

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有