ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Digital Roots

2021-10-04 23:34:54  阅读:195  来源: 互联网

标签:digit int digital single Digital integer root Roots


The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

思路:

暴力递归!

但是要注意一个细节,不能直接使用数进行操作,会越界,建议使用字符串来得到第一个数字,然后放到递归函数里去!

代码:

#include<stdio.h>
#include<string.h>
int dfs(int n){//构建一个递归函数
	int b = 0;
	while(n>0){
		b = b + (n%10);
		n = n /10;
	}
	if(b>9) return dfs(b);
	else printf("%d\n",b); 
}
int main()
{
	int i=0,j,k;
	char ch[10010];
	while(scanf("%s",&ch)!=EOF)
	{
		k = strlen(ch);
		if(ch[0]=='0') break;
		else{
			for(j=0;j<k;j++){//用字符来输入!!!
				i += ch[j] - '0';
			}
		}
		dfs(i);
		i=0;//注意归0
	 } 
	 return 0;
}

标签:digit,int,digital,single,Digital,integer,root,Roots
来源: https://blog.csdn.net/weixin_60789461/article/details/120609604

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有