ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT (Advanced Level) 1068 Find More Coins (背包问题)

2021-08-22 12:32:30  阅读:166  来源: 互联网

标签:1068 PAT Level int money coins index new Integer


1068 Find More Coins (30 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104, the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1≤V2​≤⋯≤Vk​ such that V1+V2+⋯+Vk=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1
 

Sample Output 1:

1 3 5
 

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution



import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;

public class Main {
     public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));

        String s = reader.readLine();
        String[] split = s.split(" ");
        int N = Integer.parseInt(split[0]); // 硬币总数
        int M = Integer.parseInt(split[1]); //待付金额

        String s1 = reader.readLine();
        String[] s2 = s1.split(" ");
        Integer[] coins = new Integer[N];          //拥有的硬币面额
        for (int i = 0; i < N; i++) {
            coins[i] = Integer.parseInt(s2[i]);
        }
        FindMoreCoins(M, N, coins);
    }

    public static void FindMoreCoins(int money, int total, Integer[] coins){
        int n = coins.length;
        int[] dp = new int[money + 1];
        boolean[][] flag = new boolean[total+1][money + 1];
        Arrays.fill(dp, -1);
        dp[0] = 0;
        Arrays.sort(coins, new Comparator<Integer>() {
            @Override
            public int compare(Integer o1, Integer o2) {
                return o2 - o1;
            }
        });

        for (int i = 0; i < n; i++){
            int coin = coins[i];
            for (int j = money; j >= coin; j--){
                if (dp[j] <= dp[j - coin] + coin){
                    dp[j] =  dp[j - coin] + coin;
                    flag[i+1][j] = true;
                }
            }
        }
        if (dp[money] != money){
            System.out.println("No Solution");
        }else {
            ArrayList<Integer> arr = new ArrayList<>();
            int v = money, index = n;
            while(v > 0) {
                if(flag[index][v] == true) {
                    arr.add(coins[index-1]);
                    v -= coins[index-1];
                }
                index--;
            }
            for(int i = 0; i < arr.size(); i++) {
                if(i != 0) System.out.print(" ");
                System.out.print(arr.get(i));
            }
        }
    }
}

  

 

 

   

标签:1068,PAT,Level,int,money,coins,index,new,Integer
来源: https://www.cnblogs.com/jasonXY/p/15171906.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有