ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HDU-1062-Text Reverse(栈)

2021-08-07 12:58:15  阅读:192  来源: 互联网

标签:HDU ch Text 1062 single words test line cases


题目

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

解题思路:

创建一个栈每输入一个字符就存入栈,当遇到空格或者换行时将栈中的字符全部输出

完整代码

#include<iostream>
#include<stack> 
using namespace std;
int main()
{
	int n,m,i,j;
	char ch;
	cin>>n;
	getchar();
	while(n--)
	{
		stack<char>s;
		while(true)
		{
			ch = getchar();
			
			if(ch==' '||ch=='\n')
			{
				while(!s.empty())
				{
					cout<<s.top();
					s.pop();
				}
				if(ch=='\n')
				break;
				cout<<" ";
			}
			else
			{
				s.push(ch);
			}
		}
		cout<<"\n"; 
	}
	return 0;
}

标签:HDU,ch,Text,1062,single,words,test,line,cases
来源: https://blog.csdn.net/m0_56861113/article/details/119484840

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有