ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

关于虚拟原点

2021-08-03 20:00:47  阅读:190  来源: 互联网

标签:原点 int visit 虚拟 Kiki 关于 jk


虚拟原点多用于图论中,就是再建一个点,使得他对于其他点的距离等于那个点的某一些特性,在用spfa算法求负环的时候要开一个虚拟原点,因为不能保证这个图是能通过一个点就能全走到的,spfa算法是设置一个起点,然后就是需要把这个起点设置成0号点,然后把其他的点都与这个点连接起来,这个边权就是这个点的属性,比如说这个点是起点的话,dis是0,所以0号点到这个点的距离就是0,下面来看一个题

Choose the best route

 One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n. 

Input

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

这个就是多个起点一个终点,这个就可以建一个虚拟原点,然后把每一个起点与这个虚拟原点的距离都设置成0,然后把这个虚拟原点设置成起点,然后求出这个点与终点的距离就行了,
下面看代码

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int inf=10000000;
int n,m,s;
int p[1001][1001];
int visit[1001];
int des[1001];
int dijkstra()
{
 int i,j,temp,k;
 memset(visit,0,sizeof(visit));
 for(i=0;i<=n;i++) des[i]=p[0][i];
 des[0]=0;
 visit[0]=1;
 for(i=0;i<=n;i++)
 {
  temp=inf;
  for(j=0;j<=n;j++)
  {
   if(visit[j]==0&&des[j]<temp)
   {
    temp=des[j];
    k=j;
   }
  }
  visit[k]=1;
  if(temp==inf) break;
  for(j=0;j<=n;j++)
  {
   if(visit[j]==0&&des[k]+p[k][j]<des[j]) des[j]=des[k]+p[k][j];
  }
 }
 return des[s];
}
int main()
{
 int a,b,c,mm,x,r,jk,i,j;
    while(scanf("%d %d %d",&n,&m,&s)!=EOF)
 {
  jk=10000000;
  for(i=0;i<=n;i++)
  {
   for(j=0;j<=n;j++)
   {
    p[i][j]=inf;
   }
  }
        for(i=1;i<=m;i++)
  {
   scanf("%d %d %d",&a,&b,&c);
   if(p[a][b]>c)
   {
    p[a][b]=c;
   }
  }
  scanf("%d",&mm);
  for(i=0;i<mm;i++)
  {
   scanf("%d",&x);
            p[0][x]=0;
  }
  jk=dijkstra();
  if(jk==10000000) puts("-1");
  else printf("%d\n",jk);
 }
 return 0;
}

标签:原点,int,visit,虚拟,Kiki,关于,jk
来源: https://blog.csdn.net/weixin_51979465/article/details/119357453

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有