ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

POJ 2386 Lake Counting

2019-02-05 21:37:53  阅读:338  来源: 互联网

标签:John .. int Lake WW field POJ Farmer Counting


Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 48370   Accepted: 23775

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

USACO 2004 November

【题意】

对于一个图,八个方向代表相邻,求出相邻的(联通)块的个数

 

【分析】


以一个点W为入口将相邻的W 深搜一遍,同时将他改掉,避免重搜

 

【代码】

#include<cstdio>
using namespace std;
const int N=105;
int n,m,ans,dir[8][2]={{0,1},{0,-1},{1,0},{-1,0},{-1,-1},{1,-1},{1,1},{-1,1}};
char mp[N][N];
void dfs(int x,int y){
	mp[x][y]='.';
	for(int i=0;i<8;i++){
		int nx=x+dir[i][0];
		int ny=y+dir[i][1];
		if(nx<1||ny<1||nx>n||ny>m||mp[nx][ny]=='.') continue;
		dfs(nx,ny);
	}
}
inline void Init(){
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++) scanf("%s",mp[i]+1);
}
inline void Solve(){
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			if(mp[i][j]=='W'){
				dfs(i,j);
				ans++;
			}
		}
	}
	printf("%d",ans);
}
int main(){
	Init();
	Solve();
	return 0;
} 
 


 

 

 

标签:John,..,int,Lake,WW,field,POJ,Farmer,Counting
来源: https://www.cnblogs.com/shenben/p/10353174.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有