ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1039 Course List for Student(字符串哈希)

2019-02-03 19:39:37  阅读:254  来源: 互联网

标签:JAY9 Student courses LOR6 List Course student line BOB5


Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤), the number of students who look for their course lists, and K (≤), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

注意点:

  1. map<string, vector<int> >会导致超时
  2. 数据量庞大,不要使用cin和cout输入输出
  3. 使用二维数组,会导致最后一组数据内存超限,因此需要使用vector

总的来说,这算是一道套路题,字符串都给的简短且工整正是暗示了转化哈希的思路,vector的使用也不复杂,趟过这个坑这类题以后应该问题不大。

 

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=26*26*26*10+1;
vector<int> v[maxn];

int get(char c[]){
    int id=0;
    for(int i=0;i<3;i++){
        id=id*26+c[i]-'A';
    }
    id=id*10+c[3]-'0';
    return id;
}

int main(){
    int n,m,a,b;
    char temp[5];
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&b);
        for(int j=0;j<b;j++){
            scanf("%s",temp);
            int id=get(temp);
            v[id].push_back(a);
        }
    }
    for(int i=0;i<n;i++){
        scanf("%s",temp);
        int id=get(temp);
        sort(v[id].begin(),v[id].end());
        printf("%s %d",temp,v[id].size());
        for(int j=0;j<v[id].size();j++)
            printf(" %d",v[id][j]);
        printf("\n");
    }
    return 0;
}

 

标签:JAY9,Student,courses,LOR6,List,Course,student,line,BOB5
来源: https://www.cnblogs.com/exciting/p/10350869.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有