ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

POJ 3280 Cheapest Palindrome

2019-02-03 17:51:53  阅读:238  来源: 互联网

标签:Palindrome string Cheapest int tag cost POJ ID dp


Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.     区间dp dp[i][j] 表示 i 到 j 这个区间修改成回文的最小代价。 大区间从小区间递推得到。dp[i][j] 从 dp[i][j-1]、dp[i+1][j]、dp[i+1][j-1] 这三个相邻的子区间递推。 所以 i从大到小循环,j从小到大循环。 如果str[i] = str[j] 那么dp[i][j] = dp[i+1][j-1] 然后再从dp[i+1][j] 、dp[i][j-1]中找最小值    
#include<cstdio>
#include<algorithm>
using namespace std;

int dp[2005][2005] = {0};
int add[127]={0},del[127]={0};
int main(){
    int n, m;
    char str[2005];
    scanf("%d%d",&n,&m);
    scanf("%s",str);

    for(int i=0;i<n;i++){
        getchar();
        char c = getchar();
        scanf("%d%d",&add[c],&del[c]);
    }

    for(int i=m-1;i>=0;i--){
        dp[i][i] = 0;
        for(int j=i+1;j<m;j++){
            dp[i][j] = 0x3f3f3f3f;
            if(str[i]==str[j])
                dp[i][j] = dp[i+1][j-1];
            dp[i][j] = min(dp[i][j],min(dp[i+1][j]+add[str[i]],dp[i+1][j]+del[str[i]]));
            dp[i][j] = min(dp[i][j],min(dp[i][j-1]+add[str[j]],dp[i][j-1]+del[str[j]]));

        }
    }
    printf("%d\n",dp[0][m-1]);
    return 0;
}
View Code

 

 

标签:Palindrome,string,Cheapest,int,tag,cost,POJ,ID,dp
来源: https://www.cnblogs.com/kongbb/p/10350736.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有